Jump to content


Photo

Now You're Playing with Power. The NES.


  • Please log in to reply
32 replies to this topic

#16 Moodmon

Moodmon
  • Founding Member
  • 2,163 posts

Posted 11 March 2014 - 07:33 PM

Never played a Turrican game.  Instead I played the completely unrelated Universal Soldier on Mega Drive.

 

 

Errr...(boss around 1:25 is hilarious)



#17 uiruki

uiruki
  • Founding Member
  • 1,516 posts

Posted 11 March 2014 - 09:40 PM

In fairness it was a bit of a lame boss in Turrican 2 as well! Not sure about the music conversion either...

 

I do have a bit of a soft spot for Turrican, even though I normally don't get on with platformers. Not sure why - I think it's the jump physics. You really ping into the air.



#18 shadowman

shadowman
  • Full member
  • 1,275 posts
  • Steam Profile

Posted 12 March 2014 - 09:03 AM

In fairness it was a bit of a lame boss in Turrican 2 as well! Not sure about the music conversion either...

 

I do have a bit of a soft spot for Turrican, even though I normally don't get on with platformers. Not sure why - I think it's the jump physics. You really ping into the air.

 

The music was pretty awful on the Mega Drive version. I remember playing it and that stuck out to me, as well as the terrible new levels that were added to the game. The Amiga version has a fantastic soundtrack, leagues better than the MD version!



#19 bowser123

bowser123

    Habadoodee! With a Reep-a-nazza.

  • Moderators
  • 2,914 posts

Posted 13 March 2014 - 11:33 PM

2qs7ale.png

 
Still playing and enjoying Faxanadu. Did some research and found that it wasn't the only game in the series (thanks to the excellent Hardcore Gaming 101 site), that there are a few games called Xanadu which continue the story. They themselves are part of a bigger label of games that are grouped together called the Dragon Slayer games, titles that share similar themes and gigantic dungeons and all made by the same developer, Falcom.
 
Legacy of the Wizard is one such title that I liked the look of and have began playing. In style it's very exploratory and open ended with many facets similar to Metroid.
 
So far I'm undecided about the game. It's interesting in concept and implementation, initially looks and plays brilliantly. It's deliberately obtuse and frustrating, probably near impossible to complete if you were a kid playing it in the 80s. Some mechanics of it are wonderful, some seemingly implemented deliberately with the intention of being nothing more than one great big joke or windup.
 
At times I thought the developer must hate the player such is the confusion the game raises. At other times I've considered it to possibly be one of the finest things I've ever played. What I do know is it's got me hooked, warts and all. I hope I can persevere as I think the outcome will be rewarding.

 
2z5p1d0.png20jfdp0.png33kxbb6.png

The game features 5 characters (central picture) who are all playable and must combine and work together to progress. Each has their own move set and abilities that are unique to them.
 
Four of them are family. The Dad, Mum, Son and Daughter. Plus the domesticated pet monster dragon thing. Each has different capabilities in how high they can jump, how potent their attack is (labelled distance in the pic and refers to how far the magic attack reaches) and how strong they are which corresponds to HP. The monster, being a monster, doesn't necessarily need to attack or defend as his monster buddies don't attack him.
 
At least I think they're family. The game never really elaborates on the issue. Then again it doesn't explain much in general.
 
=========================
Frustrating issues #1, # 2 and 3;
Or how NOTHING is explained:
 
I have no idea who these people are nor do I really know just what the game is about. I think  the idea is to collect items to help me defeat a dragon who lives near the start who I can see but can't touch. This extends to the items in the shop that have to be bought blindly as there's no name or explanation to them. More pressingly the game has no map or sign posts, no NPCs to help me along. I often literally have no idea where to go or just what to do as the game tells you nothing.
=========================
 
Item screen and characters.
Perhaps more interestingly is the top row of items in the right hand picture which equip the character with exclusive items and abilities. Items in purple can't be used by that particular character. That snap is old and I've found more, though not everything. It breaks down like this:
 
Dad, top left in the family picture- Rugged, axe wielding strong man. Doesn't really do jumping but gets an item (the glove graphic) that lets him lift and move blocks.
 
Mum, to the right of her husband-  Sorceress. Again no jumping expert. Yet to find her item or work out just what she does.
 
Son, left side- Seems utterly useless.
 
Daughter, bottom row- Easily my most used character. Jumps high, can equip better wands.
 
There's armour, a shield that repels magic attacks. A pickaxe which presumably removes blocks (will this be for the son?) and wand improvements. The red orb on the bottom row which transports you back home and the usual health, magic, money and key drops. Areas are blocked off and only really opened by certain characters clearing the way, or more often, the daughter finds an item that her family can use to help them get further. She does the donkey work, the family reap the rewards.
 
=========================
Frustrating issues #4;
Or the (lack of) character swapping mechanic:
 
Most games feature one protagonist that finds an item to help them progress. In other games with more than one hero you can hot swap them in and out. Alternatively the game decides when you use one and automatically swaps them out. In Legacy of the Wizard it works differently.
 
To swap character you must go home. This can be quickly and easily done if you have the red orb. Problem is they're expensive, money is tight and not every shop stocks them. So without this item, in this mammoth dungeon, you have to track all the way back home to get Dad. Then dad has to go all the way back to where you left off to continue. So much time is spent trekking back and forth, an issue worsened by the fact you never really know where you're supposed to be going or what precisely you should be doing. Then the whole issue of no map, checkpoint or markers.
=========================
 

2pt5efl.png2cnh6id.png24nmhkl.png
 
Every character attacks with a weapon, be it wand, axe or whatever the useless son does. To use the attack depletes the magic bar at an alarming rate. Defeated enemies occasionally drop top ups, just like they drop health and money. However there's no standard attack so just how do you kill if you have no magic?
 
=========================
Frustrating issues #5;
Or stuck without save states:
 
So what do you do without magic? You die as you can't kill an enemy, without killing an enemy you can't get magic drops, so you cuss and then load the save state. At best you hope, pray and wish you can jump like Mario to avoid the enemy and hopefully get to an inn (middle pic) where you can heal. So long as you have the money to pay for this service. The same money you get from defeating enemies with the magic you don't have... hope, pray, wish or load save state.
=========================
 
Many enemies can now be defeated in one hit now I've upgraded the wand on the girl. The drawback is she uses 2 magic per shot, but I've got good at controlled fire. Helpfully she can also shoot further, across about 3/4 of the screen so few shots are wasted. Early doors I thought I was playing Contra and spammed shots which resulted in no magic left. You can always go home (right pic) to heal for free but that often means travelling great lengths, trying to avoid enemies and not getting lost. Maybe the best idea is to practice controlled fire.
 
The enemies are quite varied in both appearance and attack. Some are fast or slow, moving in lines. Other bounce around and are difficult to hit like the Knights, whilst the Castlevania style Medusa heads are just as annoying in this as they are in CV. It can be quite taxing trying to work out their attack patterns so that they can be defeated with minimal magic, at times requiring skill and dexterity to defeat the foe.
 
efsc5l.png2u46j2f.png1tkdwg.png
 
Who knows why the family want to leave their lovely spacious home, which conveniently has a corner shop on it's door step. Maybe it was the intrigue of the giant, 6,936 foot ladder which leads into the vast maze below. Or go in just for shits and giggles. The game so far hasn't really said just what their motivation is.
 
What I do know is the open ended, go where you want labyrinth like areas are quite pretty and clean, intriguingly designed with bits that are constantly asking you to think just how you can progress. The tunes are low in number but high in quality, I like the soundtrack.
None of the many, many rooms have been repeated or mirrored, no 2 are identical or even that similar. The complexity of how to navigate each room is quite high, an issue worsened by the fact you never really know just if you should even be in that room.
 
The map truly is ridiculous though. There isn't one ingame but the clever people at Hardcore gaming pieced one together. Zoom in and marvel at the majesty of the scope for exploration, the craziness at the sheer number of rooms. Then remember you don't really know just where to go, when to do it or why.
 
24c8k7c.jpg
 

=========================
Frustrating issues #6;
Or is it possible to complete this game?
 
So far I haven't used a FAQ or guide, nor have I really looked closely at that map. I have save stated frequently. That map though, it's both immense and crazy. Just how was the game played and completed originally?
=========================
 
Each character can jump different heights so initially the best hope is pick the girl who jumps the highest and just go explore. Another unique idea is that the jump height also determines just how far you can fall without taking damage- the larger the jump you can make, the higher from which you can fall without damage.
 
One last big sting in the tail comes in the form of what the game let's you know, how much you are expected to discover and just how much is so obtuse to the point of being stupid.
 
2uqd8ud.png
In this one it's fairly obvious that the blue block at the top of the stairs is a secret one that can be walked through. Get near and the block disappears to reveal a path through.

=========================
Frustrating issues #7;
Or does this room contain a secret passage or not?
2090fpe.png
Does this room contain a secret passage? The issue here is the sheer number of rooms and no discernible method other than trial or error of jumping into walls to discover just what is hidden and what is solid.
=========================
 
 
The game is quite intimidating, an issue I fear may become insurmountable if gets even more frustrating. At the same time I've enjoyed exploring the expansive map, platforming and puzzling with a satisfaction upon successfully overcoming particularly hard bits. Using a combination of preparation and perseverance to progress I've delved deeper and deeper.
 
It plays nothing like a roguelike yet that's the genre I can most easily identify with this game, certainly with it's scope for difficulty and potential for aimless wandering leading to frustration and probable death.
 
When I tried the game I really liked it. Now I'm playing through it I'm not so sure what to make of it. Hopefully the threads will come together because otherwise it threatens to descend into a wild goose chase and ultimately be too much.

Edited by bowser123, 16 March 2014 - 10:51 AM.


#20 bowser123

bowser123

    Habadoodee! With a Reep-a-nazza.

  • Moderators
  • 2,914 posts

Posted 16 March 2014 - 12:06 PM

Continuation of Legacy of the Wizard, or Dragon Slayer IV Drasle Family as it's Famicom version is entitled:
 
wr10ep.png2naipar.png
 
So I've played loads more and lot's that was a mystery in the prior post has now been solved. First off, post completion, the credits named the enemies and cast, much in the same way Castlevania did. Must be an 8 bit thing.
 
As I guessed they are family with a domesticated pet monster. Dad the warrior, mum the wizard, useless son as the ranger. The elf is the real hero so well done daughter, even if laddo undeservedly gets the limelight at the end.
 
I found out there are bosses (below left), that the aim is to collect 4 crowns. Useless son then wears the crowns and is able to fight the dragon I previously mentioned. The main break through came when I stopped using the most useful character and tried some others. It also turned out the dragons room is the main hub and the starting point for 4 distinct areas which are exclusive to certain characters, at the end of each they face a boss and gain a useful item. Laddo doesn't have his own area, instead he briefly warps around sectioned off areas of others at the end.
 
The pet, Pochi, is unharmed by enemies as previously mentioned. What is also useful is that he isn't troubled by enemies but able to ride on their backs. This revelation was found by accident but once I realised I could do this I exploited it. I was able to travel across areas of spikes on their backs resulting in no damage to me. More usefully some enemies jumped, so I was able to sit on their back and wait for them to jump. Once they'd jumped I could then jump off their back in mid air with the result I was high enough to reach previously inaccessible areas.
 
This soon led me to the first boss. This spider, pictured below, can harm Pochi. Which is a relief as it'd make a pretty one sided fight if even bosses couldn't harm you. As it turned out despite the creature able to do damage it was still a total walk over and went down with total ease. Despite the anti climax I was still both happy and relieved as I'd made genuine progress, fought a boss and won a crown which all gave me insight into the games structure. It isn't just a random, walk around aimlessly simulator any more.

 
2afiyj7.png2me4w89.png
 
Another revelation again revolved around spikes. I found that if you hold up when on them you take no harm. So rows of spikes like in the picture above right became no trouble. Unsure if it's a glitch, intentional or what, all I know is the same technique works in the real cart. So, being able to travel across such vast areas unharmed opened up more new sections, as did the glove toy won from the spider segment before.
 
The glove allows warrior dad to move specific blocks and objects, these things often previously acting as an impediment to progress. The item can also be used when you are stood on a block. Doing so move it one space and can be manipulated so that it becomes a mini transporter to traverse more areas.
 
One such area is below, in the left picture. The gold blocks above the warriors head, that bridge the gap above from left to right, are infact hollow. You fall through them if you step on them and all across the gap are like this. The solution is to manipulate the blue/white block in the bottom right of the image up to the top of the screen.
 
Another answer is just why does the game have ladders that appear to lead to no place? Early on in the game I regularly saw such situations and wasted time trying to jump into them. As it later turns out they're there to reset puzzles such as the gap puzzle one I just described. You leave the room, go straight back in and the puzzle is reset.
 
95plsm.png---23j6g5l.png
 
=========================
Frustrating issues #8;
Or how regular looking blocks aren't that regular:
 
The fact the gold blocks above aren't real isn't an issue. You quickly discover this by walking on them, there's no real harm done when you fall through and no progress is lost.
 
The problem with irregular tiles looking like normal tiles becomes apparent when they're not designed as a trap like above, but rather as a way of hiding an item or path like pictured below. I touched upon this in the previous post but it's become a major issue now I've progressed.
 
It's incredibly cheap and really, really annoying to spend ages wandering around with seemingly no way to progress. I assume I've missed something, persist to look. Then give up and consult a video. Seems like the solution was to walk through or jump into a normal looking block.
 
15mmy6x.png----dy44p.png
Where do you go? Oh, of course, it's obvious. You jump into specific tiles to reveal a gap. Obvious, eh. It's not as if there's loads of blocked off areas that aren't passable. Quite how you're supposed to know which area is hidden like this and which isn't is never breached in the game. Instead it expects you to trial and error every wall. So I gave in and consulted a FAQ.
 
Solution is the gaps you reveal. This sort of shit becomes moderately frequent as you progress. Just going down the ladder alone doesn't uncover them, you have to deliberately push a direction and A, one at a time.
30canmx.png--- fb79k.png
=========================

 

That solved, I'm more aware of such puzzles and am better at identifying areas that may require such trial and error. Sure it takes time to try different blocks but it's better than the previous of wandering and retreading areas. More bosses down, again they're easy.

 

As I enter the final third of the game I figure I'm doing OK and back to enjoying the game. Unfortunately my greatest frustration and annoyance is yet to come, a set of scenarios that leave me outright despising the game after once finding it enjoyable and fun, if obtuse and occasionally tricky.

 

2qa09zd.png



#21 bowser123

bowser123

    Habadoodee! With a Reep-a-nazza.

  • Moderators
  • 2,914 posts

Posted 16 March 2014 - 01:15 PM

My final post on the subject, a game I grew to hate. The end of the game only drew criticism from me, I really do dislike it to the extent that I'd never play it again. So much so that I've spoiled the final screen so you don't have to play it to either:

 

kbypm0.png

 

=========================
Frustrating issues #9;
Or how later items are lazy

 

One of the highlights of the game had been the item upgrades. Better wands to attack, wings that let you near fly for a limited time. Shields that block spells (rendering the bosses irrelevant), high jump boots. Even the block movers are fairly unique in implementation though not idea.

 

Best of all is a special shoe that lets you jump on an enemies head to defeat them! Huzzah! No more need to farm magic to attack. Not everyone can equip the shoes, but those that can are transformed by the ability.

 

One other late ability is immensely useful. It's a key that opens all doors and never runs out. Instead of depleting your key supply it takes off one magic segment and opens the lock that way. So the item is pretty good. The issue comes when the game decides to have several screens of nothing but locks. You couldn't realistically open them with normal keys as there's so many, you'd run out of keys way before undoing them all.. Opening some, leaving to get more and returning fails as the locks reappear when you leave, much like how enemies regenerate when you go back to a screen.

ra6h5c.png--2lihq9c.png

 

So you have on one hand the immense creativity of a sea of locks in multiple areas.

 

On the other you have the issue that even though you have the new key ability, you still run out of magic to use the damn thing. So you still have to farm enemies and back you return to killing foes for magic. Issue is you can't leave the area so are limited to one or two respawning, and the game decided the character in question can't use the boots so I can't jump on their heads.

=========================

 

=========================
Frustrating issues #10;
Or how later items are actually near useless because of their implementation

 

2zpv34l.png--21l8uts.png

 

The puzzle and solution is simple. We want to uncover the red chest which holds the magic key I was just on about. The solution is simple too- you move the blocks out of the way.

 

The issue comes with the fact it's damn near broken moving the blocks with her if they're not on the floor. I have no idea, twenty minutes later of trying later, how they finally moved in the way I wanted. It'd be nice if the game explained just how to use the item, alas, nope. Instead I save stated every time one finally moved how I wanted it to. Many reloads used later and on I progress...

 

=========================
Frustrating issues #11;
Or should be renamed game breaking bullshit that nearly caused me to stop

 

The first picture on the left is an issue that cropped up early. Defeated enemies drop items, though sometimes they drop poison which harms. Occasionally the item is dropped in a path so narrow you can do nothing to pass it. You can either take the health hit and collect the poison, or wait for it to disappear. Though annoying it isn't game breaking.

fm1icg.png---158a8pc.png

 

The real game breaker comes in the right picture. Late in the game some enemies are like slime and hide on top of a tile. Normally they are blue or green on black so visible if you go careful. Can you see an enemy on that right picture? I can't now, I couldn't in game at the time.

 

I touched the enemy and died because I was on low health. OK, reload, go careful, die again. Still can't see it. On the third death I know where the enemy is though I can't see it. You have to remember I'm reloading save states here, there are no lives in game. Death equals dumping back to the club house and stripped of everything you've collected since last leaving. Which is lots of progress.

 

I think maybe the game is glitched, the error is the emulator. Nope, I can shoot the space and the enemy doesn't die. I view a video of a real cart and their enemy is invisible on their version too.

 

The game breaker comes from the fact I can't kill the enemy. I can't jump, due to the low roof, over it. I can't get the angle to shoot it either. There are no other enemies to kill so can't get more health and take the hit that way. Sure there are extra health potions but like every other item can only be equipped at the shop or in a home. To get to the section I'm at requires me to have all three items I was holding.

 

So you have to accept death and the game kicking you all the way back. Can you see the enemy?

 

=========================
Frustrating issues #12;

More unexplained bullshit

 

So you accept death. My previous save states are miles before so of no use. What happens on a cart with no save states? No lives means this screen:

28jfh0.png

 

Standard screen, yeah?

Click retry to retry the section. Click continue to continue (ie back to the menu).

That was my understanding.

 

No, click retry means click the button that takes you back to the beginning of the game with no items, progress or save. Or a START NEW GAME button. Why isn't this explained? Why isn't the button warned about or at the very least listed second?

 

Luckily I had a save state but had all my progress been wiped out by clicking the wrong button... well, I wouldn't have finished the game.

 

 

To be continued....

 



#22 Moodmon

Moodmon
  • Founding Member
  • 2,163 posts

Posted 16 March 2014 - 04:45 PM

These posts are utterly amazing Bowser, please keep up being miserable for my entertainment ;p



#23 bowser123

bowser123

    Habadoodee! With a Reep-a-nazza.

  • Moderators
  • 2,914 posts

Posted 16 March 2014 - 07:34 PM

Ha ha Moody, thanks. There is a certain appeal to moaning about bad games you know. Not remotely in the league of that Angry Nintendo Nerd guy but I sorta understand why he is playing knowingly bad games. Definitely easier to post about too.

 

Didn't set out with that mind, like I say the game started out well!

 

 

=========================
Frustrating issues #13;

Or how the game really is broke this time

 

I fought on, persevered and reached the final boss this morning. Obtained all crowns, found the sword. This sword opens up the final section, the fight off against the dragon.

2lialnd.jpg---16a4k0y.png

 

The dragon appears, I get some hits in. He has a jump attack and can harm you if you touch him. He also has a fire breath attack that is launched if you get too close or touch the flame.

 

I died quickly, no issue, load save state. This isn't such a help as the password the game gives when you have all crowns and the sword places you nearby, so the save state is more about being able to quickly restart the fight rather than have to enter a massive code every time you want to retry.

 

OK, another quick death. I'm confused as I'm sure he's not even hitting me? Maybe the hit box has gone to shit and I'm a fraction too close. So I reload again. This time I stay as far away as possible. He's not breathing fire, I'm definitely not touching him yet I'm taking damage.

 

Got to be the return of the invisible enemy I think, maybe you say. SO I start to jump about, again far from him, again not in his fire. I'm taking damage so the enemy isn't on the ground. There's no poison or anything (visible at least).

 

Again, can you see any enemy or poison or impediment in the picture below?

 

2rvyd6q.png

 

I couldn't see anything. I knew it wasn't an item issue as the game only allows the sword in. So I consult the video, again. Amazing how my video usage increased as my enjoyment went down. In the video the guy doesn't take the damage I do. So I'm really confused. Maybe the ROM is broke? Download another, does the same, try a third and the same issue.

 

So I Google "Legacy Wizard NES dragon emulator" and one of the first links is from Gamefaqs. (Keela is the dragon I'm fighting). The link says:

 

Unfortunately, a bad side effect from playing this on a ROM is the Keela fight is bugged and you can't defeat him.

As far as I know the only way to really win is to play this on the NES.

I guess you could consider getting to Keela on a ROM winning the game, much like getting to the Ganon fight in a swordless quest of Zelda is considered winning the game (since you have to stab him with a sword to hurt him and that's not possible.)

 

 

Another link said the glitch causes the game to freeze when you enter the room, another link spoke of taking damage despite not touching the enemy.

 

I genuinely wanted to cry. I'd fought on and was about to be thwarted right at the end, at the very last. The rate at which you took damage was far too high to complete the game, even if you fought perfectly and swiftly. I was sure I'd never be able to beat him.

 

Now, of course, this issue isn't the fault of the game as such, but a result of using an emulator. I only have myself to blame for being a pirate. Didn't stop me feeling very unimpressed.

 

 

(Luckily instead of giving up I Googled further and found out certain emulators can play the final fight. So I used a different one, this time through the Xbox, and it worked. Hurray. Day saved. HAPPY HAPPY HAPPY.

Also explains why the images have changed in size and quality).

 

 

=========================
Frustrating issues #14;

Or back for one final scream:

 

Huzzah. New emulator and game loaded, password entered.

I make my way to the dragon and pray. Fight starts, I don't take any illegitimate damage.

Yeah, I can beat him. Die a few times perfecting the technique, on the third go I have the idea down.

 

Keela is the first and only boss to present difficulty.

That said the boss is still easy now I have it sussed. So I take it down, deplete it's energy completely and I win. Hurray. Sorry for the picture spoiler, but it's not like anybody will play it anyway:

 

Dead dragon on the left. He bursts into flames once he's downed. Victory dance, aye?

2qjvy47.png--2pt87bl.png

 

Nope, it's GAME OVER YEAH!

It's like a shitty horror movie and the bad guy is back for one final scream. Sure you can kill the boss but the game will magically kill you too.

 

AAAAAAARRRRRRRRRRRRRRRGGGGGHHHHHHHH

NOOOOOOOOOOOOOOOOOOO!!!!

 

Picture on the right is dead dragon but also dead bowser.

What? Dead? How, why? I took it's energy bar out.

It's another ROM glitch? Will I ever finish this shitty game? Only I can't find any reference this time to the game magically killing you. Have I found all new glitches?

 

Load the game and savestate. AGAIN. This has to be the 20th time now. Same thing happens. Mega gutted. Try one more time and this time when he's near death I change tactic. Previously I'd be dancing under his arms, moving in and out to avoid flames. The final time I repeated this, ran out, got one cheap hit in and jumped back out.

 

Huzzah, dragon dead and this time I'm not. Turns out the flames the dragon burst into had been killing me flat dead. The trick was not to get caught in them, even if pretty much one hit from them was deading me.

 

Which I think is pretty shit and really, really cheap but yeah. Perhaps to be expected given how it'd all gone previously.

 

1z4x3s2.png--2ppbwcn.png

Hooray, game over yeahhhh. Only this time game over in a good way as I never, ever EVER have to play it again. End sequence was shit too and duly spoilt.



#24 bowser123

bowser123

    Habadoodee! With a Reep-a-nazza.

  • Moderators
  • 2,914 posts

Posted 18 March 2014 - 12:20 PM

i5xbm0.png--e5jp5j.png

 

Mike the baseball fan flies to C-Island to visit his archaeologist uncle, but is dismayed to find that he's disappeared. With only a scant few clues, Mike begins his journey across a series of islands to locate his lost uncle, and in the process uncovers a devious plot concocted by the alien fiend, Zoda.

 

Which is pretty much where I'm upto now, Chapter 4 and uncovering the alien conspiracy stuff.

 

What drew me to try this game was that it's a proper Nintendo developed game, one that I'd never heard of before. Released late in the life of the NES (it's US only sequel was the second to last ever NES release in 1994), StarTropics is an abandoned series that has the unique claim of being 1st party developed but never released in Japan. Turns out the internal team that made the game also did Punch Out but largely focus on designing the hardware and some accessories for Nintendo.

 

Quite excited to play a new Nintendo developed game I set off and have encountered monsters, puzzle, largely unhelpful characters and intelligent if somewhat random animals.

 

dfu4n8.png--546ans.png

 

Early to mid impressions are the game plays fairly similarly to the original NES Zelda, with 2D top down perspective overworlds linking dungeons. Once inside the dungeons the graphics change and become more detailed and zoomed in. StarTropics is split into numerous chapters that begin and end with a small story update and sometimes video.

 

One main difference between this and Zelda is that this title is almost entirely linear. You are funnelled from area to area with no scope to deviate from the path or even return to old areas. There is only ever one way forward and so far it's revolved around getting something for an NPC so that they open the path to the next bit. This perhaps is no surprise given the game is much more story driven. Outside you have limited access to some items and vehicles but these are all restricted in use. Graphically outside of the dungeon is very limited and basic.

 

Once inside the dungeon you start off equipped with a yo-yo to attack and hearts that deplete when hit. You begin with three lives and infinite continues, the game also providing a proper save at the start and end of every dungeon. Other items that can be found include ranged weapons, torches and potions. All are limited use and the game is quite stingy in replenishing them so it's important to be frugal as merely defeating an enemy often doesn't result in fresh supplies. These items also don't carry over and have to be rediscovered in every new dungeon.

 

2elv4gj.png--rgxit3.png

 

Pretty much what you do at the start of the game is what you'll be doing throughout. There's little variation to any of the games style of puzzles, battles or mechanics.

 

StarTropics initially feels clunky and unresponsive in the dungeons. This is largely down to the movement being almost grid based, direction only possible in 4 axis and one square at a time. He jumps but this is a predetermined height, able to hop over water or onto tiles (the solid, light green blocks above right). He can only leap over one space though and should you land in the water this results in instant death.

 

These tiles form the majority of the game. Each has to be individually jumped on, there's no walking from one tile to another. The game often makes it so they have to be traversed in a certain order to progress and the difficulty comes from working out the correct order. Often the tiles change to reveal a switch that will open a new bit or sometimes unveil a new tile or item. The enemies will also move onto them which can become a bit tight as you're operating in restricted spaces and being attacked from various sides. Running into an area and attacking gung-ho isn't really recommended either- you have to be a bit smarter. Watching their movements and attack patterns, striking when exposed is much more fruitful as taking enemy damage is serious, especially when the heart top ups are sparse.

 

I've found this more strategic combat a welcome change to the more arcadey style action RPG. The controls felt clunky initially but now I've adapted they serve the game well. Initially I wasn't sure on the tile hopping gameplay but as I've played more I don't mind it now. Largely it's the same action from dungeon to dungeon, but the trick is the refinement of the rules in what it does and doesn't allow from area to area. Often a new item is the source of how the game changes, the lineup and increased difficulty in what order to hop another.

 

o5njh3.png--2zf261l.png

 

At the end of every dungeon is a new boss, like the dude in the above right picture, so far every fight has been different and fairly touch. Each requires a different technique to defeat the boss. These encounters though predictable in their placement have all been fun and tricky, one of the games highlights.

 

Jumping from tile to tile is one of the games constants but it also has several other tricks that are often repeated, before being refined and made harder. The game itself has become quite challenging at around chapter 4. One trick they have introduced comes in the left picture. You enter the screen and it's lit, a second or two later it's plunged into darkness. The game expects you to memorise a rough layout of the room in your mind and make you way through in the dark.

 

Luckily you can't walk into the insta-death water, but you can very much jump into it and die. This is frustrating at times as losing all your lives puts you back to the start of the dungeon. That said continues are infinite so it's never a great slog to get back. The solution in these dark rooms is often to watch the enemy and where  they walk. Don't kill them

 

Another thing the game absolutely loves is the hidden entrance to a new opening. It's been pretty relentless in using this trick. Both on the main town map and in dungeons the game requires you to pay close attention to subtle differences that mark areas which may look impassable but are infact fresh openings. Generally there's a small black marking like in the left dungeon picture below, other times it's a placement thing that reveals the path.

 

Generally the rooms are made up of one big screen that scroll to the next. Generally they all link and there are no dead ends or useless rooms, so if you can't progress in one screen chances are there's a hidden entrance on it. Another thing the game has recently introduced is invisible enemies like the ghost below. You have to pause the game, select an item and use it to reveal the ghost. In that room the solution was kill all the (once hidden, invisible) ghosts and then the door will open.

 

2hs3iw1.png--29gdimq.png

 

Another, more annoying trick is the exit like the pictured stairs that doesn't lead to a new area but out of the dungeon and back to the start. I'm not fooled by it anymore but it was a cruel trick to dump me out.

 

 

So far so good I think.

It's an odd mix of the basic (graphics in places, palette change dungeons) and refined (puzzles, boss fights. It doesn't feel like a Nintendo game in some ways given how it can be repetitive, linear and story driven yet has been decent fun so far. I just want my sub back and maybe even a little more chance to explore in it.

 

The game is definitely becoming trickier and I anticipate it'll ramp up some more. This too is fairly different to the usual Nintendo method of a fairly constant though level challenge. It's already bringing more enemies on screen in one fight like all those mummies below, them often faster and smarter than what came before. Some too have only been defeatable using the limited stock items.

 

66znki.png--2gsh9y1.png


Edited by bowser123, 18 March 2014 - 12:25 PM.


#25 MrToad

MrToad

    Barcode Battler

  • Full member
  • 1,597 posts

Posted 18 March 2014 - 02:02 PM

These posts are utterly amazing Bowser, please keep up being miserable for my entertainment ;p

 

Having just read (and laughed) through the epic struggle with Legacy of the Wizard/Dragon Slayer I can only agree :D



#26 bowser123

bowser123

    Habadoodee! With a Reep-a-nazza.

  • Moderators
  • 2,914 posts

Posted 19 March 2014 - 07:36 AM

Re: Legacy of the Wizard and it being part of Dragon Slayer series. Was reading a post made on romhacking.net which has provided a translation patch for another game in the series, Dragon Slayer Jr: Romancia.

 

Dragon Slayer Jr. - Romancia is somewhat a Wonder Boy/Monster World and Popful Mail clone, whereas Action RPG’s mixed with side-scrolling fun, you go to various places, meet people, buy their stuff and hack-slash your way to victory! Another NES gem to check out!

 

Ooh, I like Wonder Boy and had the briefest of goes on Popful, which I liked. The Jr title apparently means it's more friendly too compared to the other games.

 

It also features enhancements to game play to make the game more playable/enjoyable including:

  • bug fixes to the original code
  • script embellishment for better hints
  • (optional) restoration of a previously unattainable item
  • (optional) removal of the main situation that required you to have to restart the game

 

Yeah, great! They improved it too.

 

Although greatly improved from when it was first beta tested, figuring out what to do in the game is still the most difficult part, and none of us can kill the final boss without extensive use of save-states.

 

Uh oh, figuring out what to do. Or the exact problem for a potential

Frustrating issues #134;

Or how I hate Falcom:

 

Sounds like a candidate for next game to try, eh :)


Edited by bowser123, 19 March 2014 - 07:37 AM.


#27 shadowman

shadowman
  • Full member
  • 1,275 posts
  • Steam Profile

Posted 17 June 2014 - 04:37 PM

So after Retro gamers later issue highlighting some of the hardest games out there I felt the need to play my Famicom again (after all, most of the games on the list were NES games, half of which I'd finished). First up, Ghosts n Goblins.

 

I've always loved the series but could never get anywhere on this game. After actually sitting through and playing the game I've finally made progress.

 

The first level is fairly easy, the one sticking point is Firebrand (the red aremer). The bastard enemy that is most evil part of the series for me, but I've finally worked out a better way of beating him without taking damage. Otherwise its an easy level, moving on...

 

Level 2 is weird, the first half of the level is over in 30 seconds. Its really easy to do and run through without issue. Problem? The second half of the level is evil. It took me ages to figure out the best way to get through the house with the huge enemies. Then the game forces you to clear a platforming area before fighting two bosses (who are thankfully rather simple).

 

Level 3 is like level 2. Easy to clear the first half, firebrand in the second half. Many red demons are a nightmare and it took me a while to get through to the boss. Problem, the boss can't be killed by your default weapon. Thanks game! Daggers work now and makes things really easy.

 

Level 4 is easy weirdly enough. Patience is the key, the boss is another dragon so as long as you have daggers its not very hard.

 

Level 5 I don't remember other than it being easier than Level 4. Either I've got better or the game is taking it easy...

 

Level 6. Taking it easy I guess, as this level is evil incarnate, I'm still stuck at the last part where you have to beat Firebrand one on one, then fight a couple more bosses, Its tough sure but its doable. I'm hoping to finish the game's first playthrough soon...



#28 qazimod

qazimod

  • Founding Member
  • 2,458 posts
  • Steam Profile

Posted 17 June 2014 - 05:37 PM

AVGN did a superb review of G 'n' G a while ago (pro tip: get the knife) - I started out on Ghouls 'n' Ghosts myself and worked my way around the series through ports and emulation. :)

 

An ace series of games, made pretty damned hard by fixed jump arcs (exactly the thing that makes Castlevania so frustrating :P ) and two-hit deaths. Among other things.



#29 shadowman

shadowman
  • Full member
  • 1,275 posts
  • Steam Profile

Posted 17 June 2014 - 09:04 PM

The knife is the all round best weapon in the game for sure. Excellent reach, rate of fire and it doesn't seem to be less damaging compared to the lance in this game.

 

I actually managed to clear my first playthrough earlier. The last bit of level 6 is a pain, mainly because the ghosts can really get in my way and of course Firebrand is a pain in the ass. The hilarious thing is that the bosses of the level are a push over, as is the final boss on level 7. The second playthrough is kicking my ass though, it seems harder but I can't put my finger on why. Still, at least now I can say I've managed to clear all the Ghosts n Golbins/Ghouls n Ghosts games at least once. I'll push to clear the second playthrough when I get a chance. I'll have to give Ghouls n Ghosts another try at some stage, I can do ok on easy mode but otherwise I get my ass handed to me late in the game.



#30 shadowman

shadowman
  • Full member
  • 1,275 posts
  • Steam Profile

Posted 18 June 2014 - 10:34 AM

Fuck yeah! (Or, I've managed to finish Ghosts n Goblins!)

photo9_zps37345b74.jpg

 

I spent the morning playing the game as I was determined to get the good ending (beating the game twice). My mini review on the game:

 

I know this seems mad but its not as hard as its made out to be, it just requires a bit of time to get all the nuances of the game down. The red devils for example are incredibly daunting at first, especially on later levels where the game forces you to fight them. The best way to fight them are to shoot them once, leap toward them shooting, then leaping backwards shooting. You should be able to evade them after you get their patterns down. You'll still get hit sometimes but it does get easier. That and it feels damn satisfying killing one of the little bastards.

 

Their are two sticking points in the game - one comes really early on in the game. After you clear the first level and then move onto the second level you'll quickly reach the checkpoint and hit a brick wall. You have to navigate through a house, kill brutish demons and dodge them fucking birds (way more annoying than Firebrand). It takes ages to get how to tackle the area (Your shots can go through walls) and it took me the majority of the time this morning clearing it both times). After that the boss fight seems almost trivial in comparison.

 

Later on at the start of level 5 you will be dodging purple demons, ghosts and skeletons in an evil first section where you WILL die loads. Get past that bit and the rest of level and boss are a push over as long as you take the right route!

 

The game isn't perfect though, odd glitches can screw you over and the collision detection raised a few eyebrows at times. Enemies brushing past me killed me, which pissed me off greatly (fucking birds...). The crouching mechanic sucks as well, its very cumbersome where it feels like I get stuck crouching and can't move... really annoying when I don't want to crouch. Also on Level 6 it felt like crouching was registering late and screwing me over (especially annoying on playthrough 2 where going for the hidden armor invokes the wrath of Firebrand!).

 

Oh, and weapons not damaging certain bosses with no visual indication in the game. That can sod off...

 

The funniest thing is that the later bosses are the easiest ones, and the final boss is a damn pushover by any measure (especially if you've fought all the way to get to him!).

 

All in all it deserves its status as a tough nut NES game and its now one of my top games for the system. It takes a while to love the game, but once you get it down you can appreciate just how damn good it is (sorta like Demons Souls in that regard). Its a really good port as well, while not 100% accurate to the arcade version (believe it or not, its easier) it still retains all the levels, enemies and bosses of the arcade version and for the most part plays really well. Its not quite Megaman, but its damn close!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users